Text To Speech Is Now Very Slow

Since the update, the text to speech in my main target language (Polish) is very slow, so nothing at all like in real life.

Also, in Android, the option to change the speed of the audio seems to have gone, as has the ability to choose different voices. Any chance of bringing these features back? If they’re still there somewhere, could someone post me a screenshot?

Thanks

2 Likes

The text to speech in Russian is also slower now.

The main reason I use Clozemaster is to improve my aural comprehension. Before the update I had the audio set to play at 2x normal speed, since the default speed is much slower than most people use in everyday life.

Please let me know where this option can be found in the update - surely such useful functionality wasn’t deliberately taken away?

2 Likes

I can confirm that the text-to-speech speed functionality has disappeared for me, which is pretty annoying. I hope that @mike will consider adding it back!

2 Likes

Yes, I’m missing this feature for Spanish too! Setting speeding to 2X is a such a great feature and main reason I subscribed.

2 Likes

Thanks for all the feedback!

The speed options are back on the web.

Will get speed options/controls added to the mobile app as well in an upcoming update.

Also discussed in Text-to-speech options off?.

Anything else just let us know. Thanks again!

3 Likes

Thanks Mike! It’s great to have this option back.

On the old version of the Android app, the text to speech used to continue to completion, even after you had clicked ‘‘NEXT’’ for the following sentence.

I found this very useful for both the speed of working the sentences and also to get into the practice of comprehending two sentences at once, something that could be useful in real life.

I can, however, understand that some people might find this feature annoying, so would it be possible to have this added but as an option this time, with a default of ‘‘Off’’?

Not sure what you’d call it, maybe ‘‘Auto-Speech Overflow’’??

@AlexG71 i think i still have this behaviour with the voices in the drop-down-menu. The sentence still plays, even if i’m already on the next one.

Very happy to have the faster speeds back. Thank you!

I thought it used to alternate between a man’s and a woman’s voice, which I appreciated. It gets a bit monotonous listening to the same voice for dozens or hundreds of sentences.

Thanks for the advice.

I’ve re-tried this and you’re correct, if you switch off the Clozemaster default audio, the text-to-speech does still overflow to the next sentence after pressing ‘‘Next’’.

However, if you do use the default Clozemaster default audio, this automatically stops after pressing ‘‘Next’’.

It’s good to have the choice :slight_smile:

(EDIT: I’ve just noted that the above method also works on the web version of the app, as well as Android).